You need to log in to create posts and topics.

Possible hardware / software error (May be known issue)


Edit: I checked some previous posts and see there is one known issue listed as "(Reopened) Touch buttons receives random events" so this may be related. I didn't notice this happening before, though.

I have just updated to the most recent version of the firmware (0.4.4) and was testing out the music card and playing audio from my phone through the Bluetooth connection. I tested the volume control between changing it on my phone and changing it on the Oboo and both are working as expected. I even tested the beep at max volume. However, after a few minutes of playing music, I noticed it was starting to get louder and louder (the speaker is really good!) but I wasn't changing anything. I disconnected the Bluetooth connection in case the problem was my phone and it kept going up, and then I switched to the timer card and noticed that the time was also going up.

What are the next steps to help diagnose this problem? Maybe there is some conductive lint or other cruft around the button or contacts?

Right now, I'm wondering if this is a hardware issue, where the button is being 'pushed' (or not debounced) when there is no contact or signal for it to happen, or if it might be a software issue where the command to handle that button press is being repeated or not confirmed somehow.

Any guidance?


Thanks for detailing your experience with the touch bar. As I explained on one of the [other post], the problem is with the sensitivity setting on the touch sensor. There are two folds to the fix. 1) to adjust the sensitivity setting so less false positive will be registered. 2) in the detection algorithm ignore all presses that is less than a minimum timeout period. We are exploring with both options, there are a lot of trial and error since capacitance can be easily varied by the environment.

SO I need to unexpectedly leave town soon.  How do I turn off the beeping alert so that I dont' get pestered with message from the family that I must make it stop or come back to pieces of a clock?


You can temporarily turn off the amplifier to disable sound all together

gpioctl dirout-low 3

Also if you keep your card on the weather page button presses won't take effect.

As the cards crash and restart eventually the audio card ends up as the active card.  Thanks for the solution. you have brought peace to my household.  🙂

You can also edit the /etc/init.d/oboo-cards file and comment out the audio card. I've actually commented everything but the weather at the moment, because even flipping to the timer, which turns on the button lights in the middle of the night, can wake me up.