You need to log in to create posts and topics.

24 hour clock mode

Is editing the /etc/config.json file and setting the hourMode to 24 suppsed to have the same effect as running the following command:

mosquitto_pub -t /set -m '{"cmd":"hour mode", "value":"24"}'

If so it doesn't work. Even after turning off the power and back on and the clock stayed in 12 hour mode until I ran the above command.

My current config file looks like this:

	"config": {
		"hourMode": 24,
		"dayNightLed": true,
		"location": "Leck, SH, DE",
		"brightnessTime": 1,
		"brightnessInfo": 7,
		"tz": "CET",
		"timezone": "CEST",
		"autoTimeZone": true
	"cards": {
		"0": {
			"name": "weather",
			"id": 0,
			"tempUnit": "celsius",
			"card": "Weather",
			"location": "Leck, SH, DE",
			"distanceUnit": "metric"


Can you try running

sh /usr/bin/

after changing the config file?

If it still doesn't work, please post the output of:

ps w
Quote from Lazar Demin on September 28, 2018, 4:59 pm

Can you try running

sh /usr/bin/

Ok, that did the trick.

I just updated to the latest firmware, did an reboot and a power off after that neither managed to update the clock to 24 hour mode but that line did the trick.

Interestingly the weather data and stuff and km/h and Celsius worked right after the reboot. just not the 24 hour mode.

Might I suggest you include that command as a last step in the update process for future firmware versions.